Re: [PATCH BlueZ 00/10 v3] mesh: Configuration storage re-org

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Michal,

On Mon, 2019-07-15 at 10:07 +0200, Michał Lowas-Rzechonek wrote:
> Hello,
> 
> On 07/14, Inga Stotland wrote:
> > + rebase off the tip
> > 
> > This set of patches introduces the notion of generic mesh-config
> > API
> > that allows the daemon to be agnostic of the underlying node
> > configuration
> > directory layout and the format of the file(s) in which node
> > configuration
> > is saved. 
> > 
> > Currently, the daemon supports only JSON-based configuration
> > format.
> > It is expected that other configuration formats may be added in
> > future.
> > 
> > As a result of these changes, storage.c and storage.h are obsolete
> > and are removed.
> > 
> > Inga Stotland (10):
> >   mesh: Move network config setup from storage.c to node.c
> >   mesh: Rename mesh-db.c to mesh-config-json.c
> >   mesh: Change mesh_db prefix to mesh_config
> >   mesh: Move load from storage functionality into node.c
> >   mesh: Confine dependency on json-c to mesh-config-json.c
> >   mesh: Replace storage_save_config with mesh_config_save_config
> >   mesh: Use mesh_config APIs to store node configuration
> >   mesh: Manage node config directory in mesh-config
> >   mesh: Create or re-use a node storage directory for keyring
> >   mesh: Rename mesh_config_srv_init() to cfgmod_server_init()
> > 
> >  Makefile.mesh                          |    3 +-
> >  mesh/appkey.c                          |   19 +-
> >  mesh/cfgmod-server.c                   |   31 +-
> >  mesh/cfgmod.h                          |    2 +-
> >  mesh/keyring.c                         |   36 +-
> >  mesh/{mesh-db.c => mesh-config-json.c} | 1071 +++++++++++++++++---
> > ----
> >  mesh/mesh-config.h                     |  172 ++++
> >  mesh/mesh-db.h                         |  157 ----
> >  mesh/mesh.c                            |   15 +-
> >  mesh/mesh.h                            |    1 +
> >  mesh/model.c                           |   23 +-
> >  mesh/net.c                             |   26 +-
> >  mesh/node.c                            |  224 +++--
> >  mesh/node.h                            |   13 +-
> >  mesh/storage.c                         |  656 ---------------
> >  mesh/storage.h                         |   51 --
> >  mesh/util.c                            |   39 +-
> >  mesh/util.h                            |    1 +
> >  18 files changed, 1219 insertions(+), 1321 deletions(-)
> >  rename mesh/{mesh-db.c => mesh-config-json.c} (58%)
> >  create mode 100644 mesh/mesh-config.h
> >  delete mode 100644 mesh/mesh-db.h
> >  delete mode 100644 mesh/storage.c
> >  delete mode 100644 mesh/storage.h
> > 
> > -- 
> > 2.21.0
> > 
> 
> Reviewed-by: Michał Lowas-Rzechonek <
> michal.lowas-rzechonek@xxxxxxxxxxx>
> 
> 
> I have a style question (as usual, unrelated to this patchset ;) - do
> we
> have a preferred way for verb usage in (public) function names?
> 
> At the moment I see:
>  - mesh_config_create vs mesh_net_new - my preference is _new/_free
>  - mesh_net_node_get vs mesh_net_get_io - my preference is to place
> verbs at the end
> 

My preference is to have verb at the end, but it seems (and maybe I am
mistaken), that bluez in general favors this style:

uint16_t bt_att_get_mtu(struct bt_att *att);
bool bt_att_set_mtu(struct bt_att *att, uint16_t mtu);

I personally don't relly like mixing the styles (although I am guilty
of this myself). So in this patch set tried to stick to the one that's
prevalent in bluez.

Best regards,
Inga

Attachment: smime.p7s
Description: S/MIME cryptographic signature


[Index of Archives]     [Bluez Devel]     [Linux Wireless Networking]     [Linux Wireless Personal Area Networking]     [Linux ATH6KL]     [Linux USB Devel]     [Linux Media Drivers]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Big List of Linux Books]

  Powered by Linux