Hello, On 07/14, Inga Stotland wrote: > + rebase off the tip > > This set of patches introduces the notion of generic mesh-config API > that allows the daemon to be agnostic of the underlying node configuration > directory layout and the format of the file(s) in which node configuration > is saved. > > Currently, the daemon supports only JSON-based configuration format. > It is expected that other configuration formats may be added in future. > > As a result of these changes, storage.c and storage.h are obsolete > and are removed. > > Inga Stotland (10): > mesh: Move network config setup from storage.c to node.c > mesh: Rename mesh-db.c to mesh-config-json.c > mesh: Change mesh_db prefix to mesh_config > mesh: Move load from storage functionality into node.c > mesh: Confine dependency on json-c to mesh-config-json.c > mesh: Replace storage_save_config with mesh_config_save_config > mesh: Use mesh_config APIs to store node configuration > mesh: Manage node config directory in mesh-config > mesh: Create or re-use a node storage directory for keyring > mesh: Rename mesh_config_srv_init() to cfgmod_server_init() > > Makefile.mesh | 3 +- > mesh/appkey.c | 19 +- > mesh/cfgmod-server.c | 31 +- > mesh/cfgmod.h | 2 +- > mesh/keyring.c | 36 +- > mesh/{mesh-db.c => mesh-config-json.c} | 1071 +++++++++++++++++------- > mesh/mesh-config.h | 172 ++++ > mesh/mesh-db.h | 157 ---- > mesh/mesh.c | 15 +- > mesh/mesh.h | 1 + > mesh/model.c | 23 +- > mesh/net.c | 26 +- > mesh/node.c | 224 +++-- > mesh/node.h | 13 +- > mesh/storage.c | 656 --------------- > mesh/storage.h | 51 -- > mesh/util.c | 39 +- > mesh/util.h | 1 + > 18 files changed, 1219 insertions(+), 1321 deletions(-) > rename mesh/{mesh-db.c => mesh-config-json.c} (58%) > create mode 100644 mesh/mesh-config.h > delete mode 100644 mesh/mesh-db.h > delete mode 100644 mesh/storage.c > delete mode 100644 mesh/storage.h > > -- > 2.21.0 > Reviewed-by: Michał Lowas-Rzechonek <michal.lowas-rzechonek@xxxxxxxxxxx> I have a style question (as usual, unrelated to this patchset ;) - do we have a preferred way for verb usage in (public) function names? At the moment I see: - mesh_config_create vs mesh_net_new - my preference is _new/_free - mesh_net_node_get vs mesh_net_get_io - my preference is to place verbs at the end -- Michał Lowas-Rzechonek <michal.lowas-rzechonek@xxxxxxxxxxx> Silvair http://silvair.com Jasnogórska 44, 31-358 Krakow, POLAND