Hi Marcel, On Fri, May 17, 2013 at 1:14 AM, Marcel Holtmann <marcel@xxxxxxxxxxxx> wrote: > Also I wonder why this is all so complicated. > > if (fd < 0) { > int n; > > n = read(fd, ...); > if (n < sizeof(...)) > seed = time(); > > close(fd); > } else > seed = time(); I intentionally avoided nested if()'s and the duplicated "seed = time(...)" assignment because it seemed to actually make it more complex IMHO. I will change to the version above, but I don't see why it is more readable than my v2 (plus the changes you proposed above). My main concern for this specific code is still to get the build fixed :) Note that the cast is necessary because "sizeof()" is unsigned. Best Regards, -- Anderson Lizardo Instituto Nokia de Tecnologia - INdT Manaus - Brazil -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html