Hi, On 14:14 Thu 24 May, Gustavo Padovan wrote: > * Gustavo Padovan <gustavo@xxxxxxxxxxx> [2012-05-24 13:56:11 -0300]: > > > > > > > > > +static void l2cap_sock_finalize_cb(void *data, int err) > > > > +{ > > > > + struct sock *sk = data; > > > > > > Why we cannot just use l2cap_sock_finalize_cb(struct sock *sk, int err) > > > what is the reason for extra assignment? > > > > Because we want to be generic here, we don't know who else will use finalize() > > so we need to keep a void * here. > > > > > > > > I also think finalize is not good name since it does not mean what is > > > actually finalized. > > > > And it is not, I failed to come with a better name here. The initial one was > > delete, even worse. > > Maybe we can go with prepare_finalize() or prepare_close() here. That sounds better, there's "teardown" too. > > Gustavo > -- > To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in > the body of a message to majordomo@xxxxxxxxxxxxxxx > More majordomo info at http://vger.kernel.org/majordomo-info.html Cheers, -- Vinicius -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html