Hi Johan, On Mon, Sep 5, 2011 at 6:55 AM, Johan Hedberg <johan.hedberg@xxxxxxxxx> wrote: > Hi Claudio, > > On Fri, Sep 02, 2011, Claudio Takahasi wrote: >> +void btd_adapter_system_unlocked(struct btd_adapter *adapter) >> +{ >> + if (!adapter->up) >> + return; >> + >> + DBG("Unlocked"); >> + >> + g_slist_foreach(adapter->devices, set_auto_connect, NULL); >> +} > > While the concept seems fine I think you've got the wrong name for the > function. You shouldn't assume that "system unlocked" is the only reason > for enabling auto-connect for the devices. It's as if you'd be pushing > policy into the core daemon ("if unlocked, then auto-connect"). Instead > the function should be named according to what it does, e.g. > btd_adapter_enable_auto_connect or btd_adapter_auto_connect_devices. > > Johan Thanks for the feedback. I gonna rename the function. I was more afraid of the concept, in theory it could be more generic, triggering connections to other services. But one step at a time, first we need to improve the handling of multiple LE connection requests(Including LE passive scanning). BR, Claudio -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html