Hi Claudio, On Fri, Sep 02, 2011, Claudio Takahasi wrote: > +void btd_adapter_system_unlocked(struct btd_adapter *adapter) > +{ > + if (!adapter->up) > + return; > + > + DBG("Unlocked"); > + > + g_slist_foreach(adapter->devices, set_auto_connect, NULL); > +} While the concept seems fine I think you've got the wrong name for the function. You shouldn't assume that "system unlocked" is the only reason for enabling auto-connect for the devices. It's as if you'd be pushing policy into the core daemon ("if unlocked, then auto-connect"). Instead the function should be named according to what it does, e.g. btd_adapter_enable_auto_connect or btd_adapter_auto_connect_devices. Johan -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html