Hi Szymon, On Tue, Nov 16, 2010, Szymon Janc wrote: > + if (!device_has_oob_data(device) > + || btd_event_user_approve(&BDADDR(index), dba)) That should be: if (!device_has_oob_data(device) || btd_event_user_approve(&BDADDR(index), dba) < 0) Otherwise it looks like btd_event_user_approve might return a boolean. > + req->msg = dbus_message_new_method_call(agent->name, agent->path, > + "org.bluez.Agent", "RequestApproval"); I think the name of this method is one of the more important things to get right before we push this upstream. I'm not so sure of the current proposal. I have a feeling that it'd be a good idea to have the term "pair" somewhere explicitly in the name. How about "RequestPairing"? I know Marcel will have something to say about this too. Johan -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html