[PATCH v2 0/5] random improvements and cleanups for elevator.c

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



The series slightly improves the readability of elevator.c.

Changes in v2:
  - add patch 3 to further improve the readability (suggested by Christoph)
  - add Reviewed-by tags from Christoph

Jinlong Chen (5):
  elevator: print none at first in elv_iosched_show even if the queue
    has a scheduler
  elevator: replace continue with else-if in elv_iosched_show
  elevator: print e->elevator_name instead of cur->elevator_name in
    elv_iosched_show
  elevator: repalce "len+name" with "name+len" in elv_iosched_show
  elevator: use bool instead of int as the return type of
    elv_iosched_allow_bio_merge

 block/elevator.c | 23 ++++++++++-------------
 1 file changed, 10 insertions(+), 13 deletions(-)

-- 
2.34.1




[Index of Archives]     [Linux RAID]     [Linux SCSI]     [Linux ATA RAID]     [IDE]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Device Mapper]

  Powered by Linux