On 06/07/2020 15:41, Ming Lei wrote:
- hctx = flush_rq->mq_hctx;if (!q->elevator) {
Is there a specific reason we do: if (!a) do x else do y as opposed to: if (a) do y else do x Do people find this easier to read or more obvious? Just wondering.
- blk_mq_tag_set_rq(hctx, flush_rq->tag, fq->orig_rq); - flush_rq->tag = -1; + flush_rq->tag = BLK_MQ_NO_TAG; } else { blk_mq_put_driver_tag(flush_rq); - flush_rq->internal_tag = -1; + flush_rq->internal_tag = BLK_MQ_NO_TAG; }