> + if (bio->bi_phys_segments == -1) > + bio->bi_phys_segments = 1; > + else > + bio->bi_phys_segments++; Minor nitpickm but I'd kust write this as: if (bio->bi_phys_segments == -1) bio->bi_phys_segments = 0; bio->bi_phys_segments++; Otherwise this looks fine: Reviewed-by: Christoph Hellwig <hch@xxxxxx>