On 12/11/18 12:08 AM, Christoph Hellwig wrote: >> + if (!(result < 0 || irq_queues == 1)) >> + irq_queues = irq_sets[0] + irq_sets[1] + 1; > > Maybe its just me, but I hate this style of conditions, why not: > > if (result >= 0 && irq_queues > 1) > irq_queues = irq_sets[0] + irq_sets[1] + 1; I'll change it, that is more readable (and logically identical). -- Jens Axboe