> + if (!(result < 0 || irq_queues == 1)) > + irq_queues = irq_sets[0] + irq_sets[1] + 1; Maybe its just me, but I hate this style of conditions, why not: if (result >= 0 && irq_queues > 1) irq_queues = irq_sets[0] + irq_sets[1] + 1; Otherwise this looks fine to me: Reviewed-by: Christoph Hellwig <hch@xxxxxx>