Re: [PATCH V2 10/20] blk-mq-sched: introduce helpers for query, change busy state

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, 2017-08-05 at 14:56 +0800, Ming Lei wrote:
> +static inline bool blk_mq_hctx_is_dispatch_busy(struct blk_mq_hw_ctx *hctx)
> +{
> +	return test_bit(BLK_MQ_S_DISPATCH_BUSY, &hctx->state);
> +}
> +
> +static inline void blk_mq_hctx_set_dispatch_busy(struct blk_mq_hw_ctx *hctx)
> +{
> +	set_bit(BLK_MQ_S_DISPATCH_BUSY, &hctx->state);
> +}
> +
> +static inline void blk_mq_hctx_clear_dispatch_busy(struct blk_mq_hw_ctx *hctx)
> +{
> +	clear_bit(BLK_MQ_S_DISPATCH_BUSY, &hctx->state);
> +}

Hello Ming,

Are these helper functions modified in a later patch? If not, please drop
this patch. One line helper functions are not useful and do not improve
readability of source code.

Thanks,

Bart.




[Index of Archives]     [Linux RAID]     [Linux SCSI]     [Linux ATA RAID]     [IDE]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Device Mapper]

  Powered by Linux