On Tue, May 16, 2023 at 05:00:29PM -0700, Bart Van Assche wrote: > On 5/16/23 16:30, Damien Le Moal wrote: >> Or if you really want to rewrite this, may be something like: >> >> static inline bool bdev_op_is_zoned_write(struct block_device *bdev, >> enum req_op op) >> { >> return bdev_is_zoned(bdev) && >> (op == REQ_OP_WRITE || op == REQ_OP_WRITE_ZEROES); >> } >> >> which is very easy to understand. > > The op_is_zoned_write() function was introduced to use it in patch 4/11 of > this series. Anyway, I will look into open-coding it. I think the idea here is that we're testing for an operation that needs zone locking. Maybe that needs to be reflected in the name? op_needs_zone_write_locking() ?