Hey Marc,
Thanks for the review!
On 2019-04-08 14:24, Marc Gonzalez wrote:
On 08/04/2019 10:30, Sibi Sankar wrote:
On 2019-04-05 20:38, Marc Gonzalez wrote:
On 27/03/2019 13:38, Sibi Sankar wrote:
Add the shared cx/mx and sensor sub-system's cx and mx
power-domains found on MSM8998.
Signed-off-by: Sibi Sankar <sibis@xxxxxxxxxxxxxx>
---
drivers/soc/qcom/rpmpd.c | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
diff --git a/drivers/soc/qcom/rpmpd.c b/drivers/soc/qcom/rpmpd.c
index 238a9e02e890..706a3f63038e 100644
--- a/drivers/soc/qcom/rpmpd.c
+++ b/drivers/soc/qcom/rpmpd.c
@@ -19,9 +19,12 @@
/* Resource types */
#define RPMPD_SMPA 0x61706d73 /* smpa */
#define RPMPD_LDOA 0x616f646c /* ldoa */
+#define RPMPD_RWCX 0x78637772 /* rwcx */
#define RPMPD_RWMX 0x786d7772 /* rwmx */
#define RPMPD_RWLC 0x636c7772 /* rwlc */
#define RPMPD_RWLM 0x6d6c7772 /* rwlm */
+#define RPMPD_RWSC 0x63737772 /* rwsc */
+#define RPMPD_RWSM 0x6d737772 /* rwsm */
I do not see any value in the comments. Maybe remove them?
comments were included to add value
though, however I guess the comments
were definitely not clear enough.
The magic values for the resources
are calculated as follows:
ascii to hex in reverse order
eg: smpa -> 0x61706d73
0x61 0x70 0x6d 0x73
a p m s
Ah... I see now.
I agree that explaining *why* e.g. RPMPD_SMPA is defined as 0x61706d73
is worthwhile indeed.
What I meant is that adding /* smpa */ to a macro named RPMPD_SMPA does
not really bring any new information ;-)
yeah I got that
How about prefixing the whole block with a small blurb, for example
/* The value of RPMPD_X is X encoded as a little-endian, lower-case,
ASCII string */
sure will add this ^^ instead in the next
re-spin
Regards.
--
-- Sibi Sankar --
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project.