On Fri, 2 Feb 2018, Lina Iyer wrote: > +++ b/include/trace/events/pdc.h > @@ -0,0 +1,55 @@ > +/* Copyright (c) 2017-2018, The Linux Foundation. All rights reserved. > + * > + * This program is free software; you can redistribute it and/or modify > + * it under the terms of the GNU General Public License version 2 and > + * only version 2 as published by the Free Software Foundation. > + * > + * This program is distributed in the hope that it will be useful, > + * but WITHOUT ANY WARRANTY; without even the implied warranty of > + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the > + * GNU General Public License for more details. Can you please use the proper SPDX identifiers instead of the boiler plate? Same for the driver source file. > + */ > + > +#undef TRACE_SYSTEM > +#define TRACE_SYSTEM pdc > + > +#if !defined(_TRACE_PDC_) || defined(TRACE_HEADER_MULTI_READ) > +#define _TRACE_PDC_H_ > + > +#include <linux/tracepoint.h> > + > +#define PDC_ENTRY 1 > +#define PDC_TYPE_CONFIG 2 > + > +TRACE_EVENT(irq_pin_config, This is really a too generic name for a PDC specific breakpoint. Aside of that the question is whether this really justifies a trace point. Wouldn't it be sufficient to use the GENERIC_IRQ_DEBUGFS infrastructure to make this accessible via debugfs? Thanks, tglx -- To unsubscribe from this list: send the line "unsubscribe linux-arm-msm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html