RE: [PATCH] pmdomain: arm: Fix debugfs node creation failure

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> Subject: Re: [PATCH] pmdomain: arm: Fix debugfs node creation failure
> 
> 
> 
> On 7/5/24 18:34, Sudeep Holla wrote:
> > On Fri, Jul 05, 2024 at 09:16:29AM +0530, Sibi Sankar wrote:
> >>
> >> On 7/4/24 16:02, Sudeep Holla wrote:
> >>>
> >>> If there are 2 perf domains for a device or group of devices, there
> >>> must be something unique about each of these domains. Why
> can't the
> >>> firmware specify the uniqueness or the difference via the name?
> >>>
> >>> The example above seems firmware is being just lazy to update it.
> >>> Also for the user/developer/debugger, the unique name might be
> more
> >>> useful than just this number.
> >>>
> >>> So please use the name(we must now have extended name if
> 16bytes are
> >>> less) to provide unique names. Please stop working around such
> silly
> >>> firmware bugs like this, it just makes using debugfs for anything
> useful harder.
> >>
> >> This is just meant to address firmware that are already out in the
> wild.
> >> That being said I don't necessarily agree with the patch either since
> >> it's penalizing firmware that actually uses a proper name by
> >> appending something inherently less useful to it. Since, the using of
> >> an unique domain name isn't required by the spec, the need for it
> >> goes under the radar for vendors. Mandating it might be the right
> >> thing to do since the kernel seems inherently expect that.
> >>
> >
> > Well I would love if spec authors can agree and mandate this. But this
> > is one of those things I can't argue as I don't necessarily agree with
> > the argument. There are 2 distinct/unique domains but firmware
> authors
> > ran out of unique names for them or just can't be bothered to care
> about it.
> >
> > They can't run out of characters as well in above examples, firmware
> > can add some useless domain ID in the name if they can't be
> bothered or creative.

As Sibi raised, Spec does not has restriction on name.

Linux chose to use genpd to support perf domain, but now it turns out
that Linux is forcing firmware to use different name for power/perf
domain. This will not convince firmware developers.

For example, firmware might be as below:

struct pd_perf_domain {
	char *name;
	(int *)power_hook(int id);
	(int *)perf_hook(int level);
};


[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [Linux for Sparc]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux