On 07/23/2015 06:31 AM, Stephen Boyd wrote:
On 07/22/2015 12:10 AM, Rajendra Nayak wrote:
@@ -104,6 +105,37 @@ static int gdsc_disable(struct generic_pm_domain
*domain)
return gdsc_toggle_logic(sc, false);
}
+static int gdsc_attach(struct generic_pm_domain *domain, struct
device *dev)
+{
+ int ret;
+ struct gdsc *sc = domain_to_gdsc(domain);
+ char **con_id, *con_ids[] = { "core", "iface", NULL };
const?
This is where I get scared of sniffing too much SoC glue. What's to
enforce the "core", and "iface" naming scheme? What's to enforce there
being two clocks vs. one? Maybe a better approach would be to use
of_clk_get() and iterate through all clocks of the device, or to encode
the clock names in the gdsc structure.
I had the clock names in the gdsc structure in v5. I should probably go
back to having it that way.
--
To unsubscribe from this list: send the line "unsubscribe linux-arm-msm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html