On Tue, May 02, 2023 at 02:22:22PM +0200, Johan Hovold wrote: > On Mon, Apr 24, 2023 at 08:40:09PM -0700, Bjorn Andersson wrote: > > diff --git a/arch/arm64/boot/dts/qcom/sc8280xp-crd.dts b/arch/arm64/boot/dts/qcom/sc8280xp-crd.dts [..] > > &mdss0_dp0_out { > > data-lanes = <0 1>; > > - remote-endpoint = <&pmic_glink_con0_ss>; > > + remote-endpoint = <&usb_0_qmpphy_dp_in>; > > }; > > It's a bit hard to follow what going on when using place holder nodes > from the dtsi like this (instead of describing all the ports directly in > the board dts). IIRC we went a bit back and forth over this earlier and > we already use this scheme for the display port controllers, so I guess > this is the price we pay for being consistent. > I agree, this is why I argued in favour of keeping the of_graphs together in a single node. But as long as we label things appropriately it's pretty ok - and the alternative would be yet another undocumented "rule". So let's stick with this... > > diff --git a/arch/arm64/boot/dts/qcom/sc8280xp.dtsi b/arch/arm64/boot/dts/qcom/sc8280xp.dtsi [..] > > + ports { > > + #address-cells = <1>; > > + #size-cells = <0>; > > + > > + port@0 { > > + reg = <0>; > > + > > + usb_0_qmpphy_out: endpoint {}; > > + }; > > + > > + port@1 { > > + reg = <1>; > > + > > + usb_0_qmpphy_dp_in: endpoint {}; > > + }; > > + }; > > }; > > The binding describes three ports, where dp-in is port 2. > > Perhaps you don't need to describe ss-in yet, but shouldn't the port > numbers match? Should some of these be described as required in the > binding? > This should certainly be port@2, thanks for spotting. Regards, Bjorn