Hi, This series has few cleanups to the MHI host stack. Apart from the cleanups, patch (5/5) removes the redundant dma_wmb() from mhi_ring_chan_db() function. I've provided the reasoning in the commit message, if my understanding is wrong please let me know. Thanks, Mani Manivannan Sadhasivam (5): bus: mhi: host: Rename process_db callback to ring_db bus: mhi: host: Rename mhi_db_brstmode() and mhi_db_brstmode_disable() bus: mhi: host: Use {READ/WITE}_ONCE macros for db_mode and db_val bus: mhi: host: Rename parse_{rsc/xfer}_event to process{rsc/xfer}_event bus: mhi: host: Remove redundant dma_wmb() before ctx wp update drivers/bus/mhi/host/init.c | 12 +++++------ drivers/bus/mhi/host/internal.h | 6 +++--- drivers/bus/mhi/host/main.c | 37 ++++++++++++++++----------------- 3 files changed, 27 insertions(+), 28 deletions(-) -- 2.25.1