The special case of SIGKILL during coredumps is very fragile today and while reading through the code I realized I have almost broken it twice. So this simplifies that special case, removes SIGNAL_GROUP_COREDUMP which has become unnecessary with the addition of signal->core_state, and this removes the helper signal_group_exit which is misnamed and is not used properly. If you squint very hard there might be a user space visible difference in behavior somewhere but I don't think there is one in practice. These patches are on top of: https://git.kernel.org/pub/scm/linux/kernel/git/ebiederm/user-namespace.git/ signal-for-v5.17 After these patches have been reviewed it is my plan to apply them to my signal-for-v5.17 branch. Eric W. Biederman (8): signal: Make SIGKILL during coredumps an explicit special case signal: Drop signals received after a fatal signal has been processed signal: Have the oom killer detect coredumps using signal->core_state signal: During coredumps set SIGNAL_GROUP_EXIT in zap_process signal: Remove SIGNAL_GROUP_COREDUMP coredump: Stop setting signal->group_exit_task signal: Rename group_exit_task group_exec_task signal: Remove the helper signal_group_exit fs/coredump.c | 20 +++++++++----------- fs/exec.c | 10 +++++----- include/linux/sched/signal.h | 18 +++--------------- kernel/exit.c | 12 ++++++++---- kernel/signal.c | 24 ++++++++++++++++-------- mm/oom_kill.c | 2 +- 6 files changed, 42 insertions(+), 44 deletions(-) Eric