Am Dienstag, den 05.05.2015, 17:19 +0200 schrieb Maxime Coquelin: > >> For example, includes/dt-bindings/mfd/stm32f4-rcc.h would look like: > >> > >> #define GPIOA 0 > >> #define GPIOB 1 > >> ... > >> #define LTDC 186 That looks a bit fragile. At least the defines for the indices should be properly namespaced, check out include/dt-bindings/gpio/tegra-gpio.h for a similar case. > >> #define STM32F4_RESET(x) (x + 128) > >> #define STM32F4_CLOCK(x) (x + 384) > >> > >> Then, in DT, a reset would be described like this: > >> > >> timer2 { > >> resets = <&rcc STM32F4_RESET(TIM2)>; > >> }; > >> > >> Phillip, Daniel, does that look acceptable to you? > > > > > > Doesn't look unreasonable. > > > > I am a little uneasy simply because there are very few similar header files > > in that directory but I haven't thought of a better idea. > > Since this file will be shared by both clock and reset drivers, I > don't see better option. > I will implement it in v8 if Philipp agrees. Are the device tree maintainers happy with this idiom spreading? Except for the point above, I think this is acceptable. regards Philipp -- To unsubscribe from this list: send the line "unsubscribe linux-arch" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html