On Mon, Mar 16, 2015 at 02:27:10PM -0400, Milosz Tanski wrote: > This patchset introduces two new syscalls preadv2 and pwritev2. They are the > same syscalls as preadv and pwrite but with a flag argument. Additionally, > preadv2 implements an extra RWF_NONBLOCK flag. There was some arugment that we just don't wait and don't have the classic unix "blocking" semantics. Maybe it's time to bite the bullet and rename it to RWF_DONTWAIT? (I personally dont really care). Second this probably needs to be on top of Al's for-next tree: https://git.kernel.org/cgit/linux/kernel/git/viro/vfs.git/log/?h=for-next Note that this has a flags field in struct kiocb, so we could just use that for the flags. Otherwise this version look fine to me, let's get it merged! Al, are yo ready to pick this up? I'd hate to miss another merge window. -- To unsubscribe from this list: send the line "unsubscribe linux-arch" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html