On Wed, Jan 5, 2011 at 11:14 AM, Peter Zijlstra <a.p.zijlstra@xxxxxxxxx> wrote: > > There appear to be only two callsites of said horror, one in the exit > path and one in ata-eh, neither appear to be performance critical so I > replaced them with a simple lock-unlock sequence. Again, WHY? What's the problem with the current code? Instead of generating ugly patches to change it, and instead of removing it, just say what the PROBLEM is. Stop this wanking already. The exit path is certainly not unimportant. And if you want to change the thing to be more efficient, I'm ok with that, as long as it's done PRETTILY instead of making the damn thing an unreadable mess. The current "spin_unlock_wait()" is obvious. I'm perfectly happy improving on it, but I would want to retain the "obvious" part, which your previous patch certainly didn't do. Some simple helper functions to extract the tail/head part of the ticket lock to make the comparisons understandable, together with always accessing the lock with the proper ACCESS_ONCE() would have made your previous patch acceptable. But you ignored that feedback, and instead you now want to do a "let's just remove it entirely patch" that is even worse. And in NEITHER version did you actually give any actual *REASON* for the change in the first place. Why? WHY? Linus -- To unsubscribe from this list: send the line "unsubscribe linux-arch" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html