On Friday, July 21, 2017 06:27:39 PM Andy Shevchenko wrote: > On Fri, Jul 21, 2017 at 3:40 PM, Rafael J. Wysocki <rjw@xxxxxxxxxxxxx> wrote: > > From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx> > > > > To prepare for a subsequent change and make the code somewhat easier > > to follow, do the following in the ACPI device wakeup handling code: > > > > * Replace wakeup.flags.enabled under struct acpi_device with > > wakeup.enable_count as that will be necessary going forward. > > > > For now, wakeup.enable_count is not allowed to grow beyond 1, > > so the current behavior is retained. > > > > * Split acpi_device_wakeup() into acpi_device_wakeup_enable() > > and acpi_device_wakeup_disable() and modify the callers of > > it accordingly. > > > > * Introduce a new acpi_wakeup_lock mutex to protect the wakeup > > enabling/disabling code from races in case it is executed > > more than once in parallel for the same device (which may > > happen for bridges theoretically). > > I prefer more self-explaining labels, though it's minor here Well, I prefer shorter ones. > To be constructive: > out -> err_unlock > out -> out_unlock or err_unlock (depends on context) > > > > +out: > > + mutex_unlock(&acpi_wakeup_lock); > > + return error; > > > +out: > > + mutex_unlock(&acpi_wakeup_lock); > > So while I don't have a particular problem with appending the "_unlock" to the "out", I'm not exactly sure why this would be an improvement. If that's just a matter of personal preference, then I would prefer to follow my personal preference here, with all due respect. [And besides, it follows the general style of this file which matters too IMO.] But if there's more to it, just please let me know. :-) Thanks, Rafael -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html