On Fri, Mar 24, 2017 at 01:03:50PM +0200, Sakari Ailus wrote: > +static int acpi_fwnode_property_read_int_array( This is really ugly way to split arguments into multiple lines IMHO. > + struct fwnode_handle *fwnode, const char *propname, > + unsigned int elem_size, void *val, size_t nval) I would much more see something like: static int acpi_fwnode_property_read_int_array(struct fwnode_handle *fwnode, const char *propname, unsigned int elem_size, void *val, size_t nval) or even static int acpi_fwnode_property_read_int_array(struct fwnode_handle *fwnode, const char *propname, unsigned int elem_size, void *val, size_t nval) ditto for all occurences. Other than that this patch looks reasonable to me. -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html