On Wednesday 03 June 2009 04:34:06 yakui_zhao wrote: > On Tue, 2009-06-02 at 21:19 +0800, Thomas Renninger wrote: > > On Sunday 31 May 2009 04:31:51 yakui_zhao wrote: > > > > > + /* > > > + * On some boxes several processors use the same processor bus id. > > > + * But they are located in different scope. For example: > > > + * \_SB.SCK0.CPU0 > > > + * \_SB.SCK1.CPU0 > > > + * Rename the processor device bus id. And the new bus id will be > > > + * generated as the following format: > > > + * CPU+CPU ID. > > > + */ > > > + sprintf(acpi_device_bid(device), "CPU%X", pr->id); > > Hm, there were several attempts to get rid of acpi_device_bid and > > friends. > > Especially here, sprintfing into something function like looks really > > wrong. > > Len, do you agree that not introducing new ones and at some point of > > time replacing: > > acpi_device_bid(device) > > with > > device->pnp.bus_id > > is the way to go? > The acpi_device_bid is not a function. It is equal to the > device->pnp.bus_id for the ACPI device. > #define acpi_device_bid(d) ((d)->pnp.bus_id) this #define should vanish sooner or later. Several people suggested to get rid of these already. Why don't you use: sprintf(device->pnp.bus_id, "CPU%X", pr->id); Unfortunately these constructs are rather common in drivers/acpi, thus I ask whether these should be avoided or not. Thomas -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html