On 26/09/2023 20:04, Rafael J. Wysocki wrote:
On Tue, Sep 26, 2023 at 7:56 PM Rafael J. Wysocki <rafael@xxxxxxxxxx> wrote:
On Tue, Sep 26, 2023 at 7:18 PM Daniel Lezcano
<daniel.lezcano@xxxxxxxxxx> wrote:
On 21/09/2023 19:49, Rafael J. Wysocki wrote:
From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
In order to reduce code duplication, merge update_passive_devices() and
update_active_devices() into one function called update_trip_devices()
that will be used for updating both the passive and active trip points.
No intentional functional impact.
Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
---
drivers/acpi/thermal.c | 53 ++++++++++++++++++-------------------------------
[ ... ]
+ if (index != ACPI_THERMAL_TRIP_PASSIVE) {
+ method[1] = 'A';
+ method[2] = 'L';
+ method[3] = '0' + index;
+ }
Could be index > 9 ?
I can add a check, but it will never be called with index > 9 anyway.
To be more precise, update_trip_devices() is called in two places,
acpi_thermal_init_trip() and acpi_thermal_update_trip_devices().
Both of these are called either with ACPI_THERMAL_TRIP_PASSIVE passed
as index, or from a loop over indices between 0 and
ACPI_THERMAL_MAX_ACTIVE-1 inclusive.
Ok, thanks for clarifying
--
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs
Follow Linaro: <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog