On Tue, Feb 19, 2008 at 04:25:02PM -0800, Harvey Harrison wrote: > On Wed, 2008-02-20 at 02:14 +0200, Adrian Bunk wrote: > > This patch fixes a check-after-use spotted by the Coverity checker. > > > > Signed-off-by: Adrian Bunk <bunk@xxxxxxxxxx> > > > > --- > > 570462ca4441d8d63dfd46efe6e5b2b1c251a611 diff --git a/drivers/thermal/thermal.c b/drivers/thermal/thermal.c > > index e782b3e..958654b 100644 > > --- a/drivers/thermal/thermal.c > > +++ b/drivers/thermal/thermal.c > > @@ -308,10 +308,10 @@ int thermal_zone_bind_cooling_device(struct thermal_zone_device *tz, > > struct thermal_cooling_device_instance *pos; > > int result; > > > > - if (trip >= tz->trips || (trip < 0 && trip != THERMAL_TRIPS_NONE)) > > + if (!tz || !cdev) > > return -EINVAL; > > > > - if (!tz || !cdev) > > + if (trip >= tz->trips || (trip < 0 && trip != THERMAL_TRIPS_NONE)) > > return -EINVAL; > > > > How about: > if (!tz || !cdev || trip >= tz->trips || > (trip < 0 && trip != THERMAL_TRIPS_NONE)) > return -EINVAL; I have no strong opinion about it, but I'd consider your suggestion less readable. > Cheers, > > Harvey cu Adrian -- "Is there not promise of rain?" Ling Tan asked suddenly out of the darkness. There had been need of rain for many days. "Only a promise," Lao Er said. Pearl S. Buck - Dragon Seed - To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html