[LARTC] [PATCH] Problem with wrong using of qdisc/filter in tc

Linux Advanced Routing and Traffic Control

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

  I found bug in tc (wrong using of qdisc/filter will cause seg fault):
   tc qdisc add u32 help        // u32 is filter
  
  In function get_qdisc_kind (get_filter_kind) we search for struct
  qdisc_util (filter_util) with name *_util (in example for u32 is 
  u32_util - it's ok, but it isn't qdisc)

  My suggestion is to change name to:
   *_utilQ (for qdisc)
   *_utilF (for filter)

  then if we search for qdisc we won't get filter (and vice versa).
  See patch.
  
  I've tested it on version 2.4.7 (ss010824 and ss020116-try), but the bug
  should also affect older versions.
   
  I wrote to A. Kuznetsov, but I didn't get response. Maybe my email
  lost or something else ;)

  Best regards
  Jarek
-- 
8  \\|||//  Jaroslaw J. Pyszny (arghil AT tlen DOT pl)      \\|||//
b   (o|o)         "Vitae,non scholae,discimus"               (o|o)
i  --\_/--  Linux user: #96704 (http://counter.li.org)      --\_/-- 
t =-> Masz 8-bit. komputer i chcesz się go pozbyc - daj znac. <-=

Attachment: iproute2-2.4.7-fix_names.patch.bz2
Description: Binary data


[Index of Archives]     [LARTC Home Page]     [Netfilter]     [Netfilter Development]     [Network Development]     [Bugtraq]     [GCC Help]     [Yosemite News]     [Linux Kernel]     [Fedora Users]
  Powered by Linux