[LARTC] etherchannel/port group/bonding plus vlan works well

Linux Advanced Routing and Traffic Control

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



I figured I should post this because before I went to do it I searched
the web for caveats etc and didn't really find much.  So anyway, I set
up bonding + vlan for a project.  Computer is dell powerdge 350 with 2
intel 82559 10/100 nic running stock 2.4.20.  I tried both the eepro100
and the e100 drivers for the nics, both work   802.1q and bonding are modules. 
Switch is cisco 2924xl-en running ios 12.0(5)XU. 

here is the bare bones of the script to bring things up on the computer
(assumes nic drivers are loaded already)

modprobe bonding
ip link set bond0 up
ip link set eth0 up
ip link set eth1 up
ifenslave bond0 eth0
ifenslave bond0 eth1
modprobe 8021q
vconfig add bond0 5
ip link set bond0.5 up 
ip address add 10.0.5.1/24 dev bond0.5
vconfig add bond0 10
ip address add 10.0.10.1/24 dev bond0.10
ip link set bond0.10 up

ANd here is the bare bones of the config for the switch

interface FastEthernet0/1
 port group 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 port group 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/5
 switchport access vlan 5
!
interface FastEthernet0/10
 switchport access vlan 10
!



and all works quite well

going to be adding pppoe, advanced shaping, and freeswan into this too.
the final result should be a pretty juicy network box :)

-

Ryan


[Index of Archives]     [LARTC Home Page]     [Netfilter]     [Netfilter Development]     [Network Development]     [Bugtraq]     [GCC Help]     [Yosemite News]     [Linux Kernel]     [Fedora Users]
  Powered by Linux