On Wed, 03 Jul 2013 17:30:40 +0200 Paolo Bonzini <pbonzini@xxxxxxxxxx> wrote: > Il 03/07/2013 16:30, Cornelia Huck ha scritto: > > + /* > > + * Return cookie in gpr 2, but don't overwrite the register if the > > + * diagnose will be handled by userspace. > > + */ > > + if (ret != -EOPNOTSUPP) > > + vcpu->run->s.regs.gprs[2] = ret; > > I think this should now be "if (ret >= 0)". Hm, we don't want to kill gpr 2's old contents if userspace will do something, which means -EOPNOTSUPP. > > > /* kvm_io_bus_write returns -EOPNOTSUPP if it found no match. */ > > The comment is now obsolete. s/kvm_io_bus_write/kvm_io_bus_write_cookie/ ? Otherwise, this is still true. > > > return ret < 0 ? ret : 0; > > Otherwise looks good, thanks! > > Paolo > -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html