On Sat, Apr 27, 2013 at 11:42:09AM +0800, Asias He wrote: > Signed-off-by: Asias He <asias@xxxxxxxxxx> Makes sense. Acked-by: Michael S. Tsirkin <mst@xxxxxxxxxx> In fact, how about we turn this around, and rename tcm_vhost.c to scsi.c and module to vhost_scsi, make tcm_vhost an alias? > --- > drivers/vhost/tcm_vhost.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/drivers/vhost/tcm_vhost.c b/drivers/vhost/tcm_vhost.c > index 1677238..bddc39a 100644 > --- a/drivers/vhost/tcm_vhost.c > +++ b/drivers/vhost/tcm_vhost.c > @@ -1928,5 +1928,6 @@ static void tcm_vhost_exit(void) > > MODULE_DESCRIPTION("TCM_VHOST series fabric driver"); > MODULE_LICENSE("GPL"); > +MODULE_ALIAS("vhost_scsi"); > module_init(tcm_vhost_init); > module_exit(tcm_vhost_exit); > -- > 1.8.1.4 -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html