On Wed, 2012-10-17 at 16:28 +0200, Avi Kivity wrote: > On 10/17/2012 04:09 PM, Marcelo Tosatti wrote: > > On Wed, Oct 17, 2012 at 12:35:33PM +0200, Avi Kivity wrote: > >> On 10/17/2012 04:10 AM, Will Auld wrote: > >> > Signed-off-by: Will Auld <will.auld@xxxxxxxxx> > >> > --- > >> > > >> > Resending to full list > >> > > >> > Marcelo, > >> > > >> > This patch is what I believe you ask for as foundational for later > >> > patches to address IA32_TSC_ADJUST. > >> > > >> > >> Please write a changelog to reflect the motivation. > >> > >> All those bool parameters scattered all over the place aren't very > >> pretty. Usually we solve this with helpers that embed the parameter > >> name (kvm_set_msr() vs. kvm_set_msr_host()) but there are too many > >> functions for this to work here. > >> > >> Marcelo, any ideas? > > > > Its easier to read > > > > kvm_x86_ops->kvm_set_msr() > > kvm_x86_ops->kvm_set_msr_host() > > > > then > > > > kvm_x86_ops->kvm_set_msr(,false) > > kvm_x86_ops->kvm_set_msr(,true) > > > > So you're right. > > Yes, but we have a million functions for setting MSRs. > > Maybe > > struct msr { > bool host_requested; > u32 index; > u64 data; > }; > > and change all the APIs to use that. > > I was working on a different solution and then saw this suggestion just now. I like this tact and will look at it closer. Thanks, Will -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html