Re: [PATCH] Added call parameter to track whether invocation originated with guest or elsewhere

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Oct 17, 2012 at 12:35:33PM +0200, Avi Kivity wrote:
> On 10/17/2012 04:10 AM, Will Auld wrote:
> > Signed-off-by: Will Auld <will.auld@xxxxxxxxx>
> > ---
> > 
> > Resending to full list
> > 
> > Marcelo,
> > 
> > This patch is what I believe you ask for as foundational for later
> > patches to address IA32_TSC_ADJUST. 
> > 
> 
> Please write a changelog to reflect the motivation.
> 
> All those bool parameters scattered all over the place aren't very
> pretty.  Usually we solve this with helpers that embed the parameter
> name (kvm_set_msr() vs. kvm_set_msr_host()) but there are too many
> functions for this to work here.
> 
> Marcelo, any ideas?

Its easier to read

kvm_x86_ops->kvm_set_msr()
kvm_x86_ops->kvm_set_msr_host()

then

kvm_x86_ops->kvm_set_msr(,false)
kvm_x86_ops->kvm_set_msr(,true)

So you're right.

--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux