On Sun, Aug 05, 2012 at 05:48:42PM +0300, Avi Kivity wrote: > On 08/05/2012 05:42 PM, Gleb Natapov wrote: > > On Sun, Aug 05, 2012 at 05:35:21PM +0300, Avi Kivity wrote: > >> On 08/05/2012 03:58 PM, Gleb Natapov wrote: > >> > Usually all APICs are HW enabled so the check can be optimized out. > >> > > >> > Signed-off-by: Gleb Natapov <gleb@xxxxxxxxxx> > >> > --- > >> > arch/x86/kvm/lapic.c | 29 ++++++++++++++++++++++++++++- > >> > arch/x86/kvm/lapic.h | 1 + > >> > arch/x86/kvm/x86.c | 1 + > >> > 3 files changed, 30 insertions(+), 1 deletion(-) > >> > > >> > diff --git a/arch/x86/kvm/lapic.c b/arch/x86/kvm/lapic.c > >> > index c3f14fe..1aa5528 100644 > >> > --- a/arch/x86/kvm/lapic.c > >> > +++ b/arch/x86/kvm/lapic.c > >> > @@ -34,6 +34,7 @@ > >> > #include <asm/current.h> > >> > #include <asm/apicdef.h> > >> > #include <linux/atomic.h> > >> > +#include <linux/jump_label.h> > >> > #include "kvm_cache_regs.h" > >> > #include "irq.h" > >> > #include "trace.h" > >> > @@ -117,9 +118,13 @@ static inline int __apic_test_and_clear_vector(int vec, void *bitmap) > >> > return __test_and_clear_bit(VEC_POS(vec), (bitmap) + REG_POS(vec)); > >> > } > >> > > >> > +struct static_key_deferred apic_hw_disabled __read_mostly; > >> > >> On top of file please. Add all_ to the name to make it clear we're > >> talking about all apics. > >> > > This is count of disabled apics really. So I think all_apic_hw_disabled > > is misleading. > > > >> > + > >> > static inline int apic_hw_enabled(struct kvm_lapic *apic) > >> > { > >> > - return (apic)->vcpu->arch.apic_base & MSR_IA32_APICBASE_ENABLE; > >> > + if (static_key_false(&apic_hw_disabled.key)) > >> > + return apic->vcpu->arch.apic_base & MSR_IA32_APICBASE_ENABLE; > >> > >> Hm, for the test to be readable, it needs to be > >> > >> if (static_key_false(&all_apics_hw_enabled)) > >> > > Exactly. all_ makes it so because apic_hw_disabled is a counter that > > counts disabled apics. So may be call it global_hw_disabled_apic_counter? > > > > The problem is how static_key_false() is defined. It returns true if > the count > 0, opposite from what I'd expect. So anything with counter > semantics will be confusing. I guess we need to pick a neutral name > (apic_disabled_key or apic_disabled_slowpath or such) to force the > reader to look at the definitions. > There was a long thread about readability of static_key_true/false and this is the result of it :( I read it this way: drop static_key_(true|false) and read the if() to understand its meaning. Now look at static_key_(true|false) to see what fast path will be in asm code. -- Gleb. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html