On Wed, Jun 01, 2011 at 03:34:23PM +0300, Avi Kivity wrote: > This mostly mindless patchset folds decode_cache into its enclosing struct, > x86_emulate_context. The point is to remove tons of pointless > > struct decode_cache *c = &ctxt->decode; > > lines from the code, which contribute absolutely nothing. > Didn't we plan some day to have a cache of decoded instructions to skip decoding stage? Not all the fields currently in decode_cache belong there of course (regs, io_read, mem_read). > Avi Kivity (2): > KVM: x86 emulator: rename decode_cache::eip to _eip > KVM: x86 emulator: fold decode_cache into x86_emulate_ctxt > > arch/x86/include/asm/kvm_emulate.h | 46 +- > arch/x86/kvm/emulate.c | 1275 +++++++++++++++++------------------- > arch/x86/kvm/trace.h | 8 +- > arch/x86/kvm/x86.c | 47 +- > 4 files changed, 631 insertions(+), 745 deletions(-) > > -- > 1.7.5.3 > > -- > To unsubscribe from this list: send the line "unsubscribe kvm" in > the body of a message to majordomo@xxxxxxxxxxxxxxx > More majordomo info at http://vger.kernel.org/majordomo-info.html -- Gleb. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html