[PATCH 0/2] Kill decode_cache

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This mostly mindless patchset folds decode_cache into its enclosing struct,
x86_emulate_context.  The point is to remove tons of pointless

       struct decode_cache *c = &ctxt->decode;

lines from the code, which contribute absolutely nothing.

Avi Kivity (2):
  KVM: x86 emulator: rename decode_cache::eip to _eip
  KVM: x86 emulator: fold decode_cache into x86_emulate_ctxt

 arch/x86/include/asm/kvm_emulate.h |   46 +-
 arch/x86/kvm/emulate.c             | 1275 +++++++++++++++++-------------------
 arch/x86/kvm/trace.h               |    8 +-
 arch/x86/kvm/x86.c                 |   47 +-
 4 files changed, 631 insertions(+), 745 deletions(-)

-- 
1.7.5.3

--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux