On 2011-04-26 18:06, Christoph Hellwig wrote: > On Tue, Apr 26, 2011 at 04:01:00PM +0200, Jan Kiszka wrote: >> +static bool modifying_bit(uint64_t old, uint64_t new, uint64_t mask) >> +{ >> + return (old ^ new) & mask; >> +} >> + > > A more usual name would be toggle_bit. But you're passing in a mask > to be modified, so it would be more a toggle_bits or toggle_mask. > This function is checking for a change. But I've no problem renaming it to toggling_bit or so if that's preferred. Jan -- Siemens AG, Corporate Technology, CT T DE IT 1 Corporate Competence Center Embedded Linux -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html