On Tue, Apr 26, 2011 at 04:01:00PM +0200, Jan Kiszka wrote: > +static bool modifying_bit(uint64_t old, uint64_t new, uint64_t mask) > +{ > + return (old ^ new) & mask; > +} > + A more usual name would be toggle_bit. But you're passing in a mask to be modified, so it would be more a toggle_bits or toggle_mask. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html