On Fri, Dec 06, 2024 at 04:45:01PM +0800, Xiaoyao Li wrote: > On 10/31/2024 3:00 AM, Rick Edgecombe wrote: > > --- a/arch/x86/include/uapi/asm/kvm.h > > +++ b/arch/x86/include/uapi/asm/kvm.h > > @@ -928,6 +928,8 @@ struct kvm_hyperv_eventfd { > > /* Trust Domain eXtension sub-ioctl() commands. */ > > enum kvm_tdx_cmd_id { > > + KVM_TDX_CAPABILITIES = 0, > > + > > KVM_TDX_CMD_NR_MAX, > > }; > > @@ -950,4 +952,11 @@ struct kvm_tdx_cmd { > > __u64 hw_error; > > }; > > +struct kvm_tdx_capabilities { > > + __u64 supported_attrs; > > + __u64 supported_xfam; > > + __u64 reserved[254]; > > + struct kvm_cpuid2 cpuid; > > Could we rename it to "configurable_cpuid" to call out that it only reports > the bits that are allowable for userspace to configure at 0 or 1 at will. Well it's already in the capabilities struct.. So to me it seems like just adding a comment should do the trick. Regards, Tony