Re: [RFC PATCH 2/6] ram_blocks: Convert to a QLIST

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Alex Williamson <alex.williamson@xxxxxxxxxx> wrote:
> On Tue, 2010-06-08 at 14:26 -0700, Chris Wright wrote:
>> * Alex Williamson (alex.williamson@xxxxxxxxxx) wrote:
>> >  extern int phys_ram_fd;
>> > -extern uint8_t *phys_ram_dirty;
>> >  extern ram_addr_t ram_size;
>> > -extern ram_addr_t last_ram_offset;
>> > +
>> > +typedef struct RAMBlock {
>> > +    uint8_t *host;
>> > +    ram_addr_t offset;
>> > +    ram_addr_t length;
>> > +    QLIST_ENTRY(RAMBlock) next;
>> > +} RAMBlock;
>> > +
>> > +typedef struct RAMList {
>> > +    uint8_t *phys_dirty;
>> > +    ram_addr_t last_offset;
>> > +    QLIST_HEAD(ram, RAMBlock) blocks;
>> > +} RAMList;
>> > +extern RAMList ram;
>> 
>> such a generic name for global namespace
>
> Well it is _the_ ram, but yea... ;)  Suggestions?

ram_block_list?

Later, Juan.
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux