* Alex Williamson (alex.williamson@xxxxxxxxxx) wrote: > On Tue, 2010-06-08 at 14:26 -0700, Chris Wright wrote: > > * Alex Williamson (alex.williamson@xxxxxxxxxx) wrote: > > > extern int phys_ram_fd; > > > -extern uint8_t *phys_ram_dirty; > > > extern ram_addr_t ram_size; > > > -extern ram_addr_t last_ram_offset; > > > + > > > +typedef struct RAMBlock { > > > + uint8_t *host; > > > + ram_addr_t offset; > > > + ram_addr_t length; > > > + QLIST_ENTRY(RAMBlock) next; > > > +} RAMBlock; > > > + > > > +typedef struct RAMList { > > > + uint8_t *phys_dirty; > > > + ram_addr_t last_offset; > > > + QLIST_HEAD(ram, RAMBlock) blocks; > > > +} RAMList; > > > +extern RAMList ram; > > > > such a generic name for global namespace > > Well it is _the_ ram, but yea... ;) Suggestions? _the_ram /me ducks -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html