On 05/05/2010 03:54 PM, Xiao Guangrong wrote:
Avi Kivity wrote:
On 04/30/2010 12:05 PM, Xiao Guangrong wrote:
If 'oos_shadow' == 0, intercepting invlpg command is really
unnecessary.
And it's good for us to compare the performance between enable
'oos_shadow'
and disable 'oos_shadow'
@@ -74,8 +74,9 @@ static int dbg = 0;
module_param(dbg, bool, 0644);
#endif
-static int oos_shadow = 1;
+int __read_mostly oos_shadow = 1;
module_param(oos_shadow, bool, 0644);
+EXPORT_SYMBOL_GPL(oos_shadow);
Please rename to kvm_oos_shadow to reduce potential for conflict with
other global names.
But really, this is a debug option, I don't expect people to run with
oos_shadow=0, so there's not much motivation to optimize it.
Agreed, but, 'oos_shadow' option is document in Documentation/kernel-parameters.txt,
if it's just a debug option, i think we do better not document it.
It has to be documented, otherwise people complain :)
Anyway the variable name and the option name don't have to be the same
(I think).
--
error compiling committee.c: too many arguments to function
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html