Re: [PATCH] KVM: VMX: Rename vmx_get_max_tdp_level to vmx_get_max_ept_level

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Aug 10, 2023, Shiyuan Gao wrote:
> In vmx, ept_level looks better than tdp level and is consistent with
> svm get_npt_level().
> 
> Signed-off-by: Shiyuan Gao <gaoshiyuan@xxxxxxxxx>
> ---
>  arch/x86/kvm/vmx/vmx.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/x86/kvm/vmx/vmx.c b/arch/x86/kvm/vmx/vmx.c
> index df461f387e20..f0cfd1f10a06 100644
> --- a/arch/x86/kvm/vmx/vmx.c
> +++ b/arch/x86/kvm/vmx/vmx.c
> @@ -3350,7 +3350,7 @@ void vmx_set_cr0(struct kvm_vcpu *vcpu, unsigned long cr0)
>  	vmx->emulation_required = vmx_emulation_required(vcpu);
>  }
>  
> -static int vmx_get_max_tdp_level(void)
> +static int vmx_get_max_ept_level(void)
>  {
>  	if (cpu_has_vmx_ept_5levels())
>  		return 5;
> @@ -8526,7 +8526,7 @@ static __init int hardware_setup(void)
>  	 */
>  	vmx_setup_me_spte_mask();
>  
> -	kvm_configure_mmu(enable_ept, 0, vmx_get_max_tdp_level(),
> +	kvm_configure_mmu(enable_ept, 0, vmx_get_max_ept_level(),
>  			  ept_caps_to_lpage_level(vmx_capability.ept));

Anyone else have an opinion on this?  I'm leaning toward applying it, but a small
part of me also kinda likes the "tdp" name (though every time I look at this patch
that part of me gets even smaller...).



[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux