David! On Tue, Feb 21 2023 at 19:10, David Woodhouse wrote: > On Tue, 2023-02-21 at 13:14 +0100, Oleksandr Natalenko wrote: > (Usama, I think my tree is fairly out of date now so I'll let you do > that? Thanks!). > > diff --git a/arch/x86/kernel/smpboot.c b/arch/x86/kernel/smpboot.c > index 50621793671d..3db77a257ae2 100644 > --- a/arch/x86/kernel/smpboot.c > +++ b/arch/x86/kernel/smpboot.c > @@ -1571,6 +1571,17 @@ void __init native_smp_prepare_cpus(unsigned int max_cpus) > > void arch_thaw_secondary_cpus_begin(void) > { > + /* > + * On suspend, smpboot_control will have been zeroed to allow the > + * boot CPU to use explicitly passed values including a temporary > + * stack. Since native_smp_prepare_cpus() won't be called again, > + * restore the appropriate value for the parallel startup modes. > + */ > + if (do_parallel_bringup) { > + smpboot_control = STARTUP_SECONDARY | > + (x2apic_mode ? STARTUP_APICID_CPUID_0B : STARTUP_APICID_CPUID_01); > + } My bad taste sensor reports: "Out of effective range" Why on earth can't you fix the wreckage exactly where it happens, i.e. in x86_acpi_suspend_lowlevel() ? --- a/arch/x86/kernel/acpi/sleep.c +++ b/arch/x86/kernel/acpi/sleep.c @@ -16,6 +16,7 @@ #include <asm/cacheflush.h> #include <asm/realmode.h> #include <asm/hypervisor.h> +#include <asm/smp.h> #include <linux/ftrace.h> #include "../../realmode/rm/wakeup.h" @@ -57,6 +58,7 @@ asmlinkage acpi_status __visible x86_acp */ int x86_acpi_suspend_lowlevel(void) { + unsigned int __maybe_unused saved_smpboot_ctrl; struct wakeup_header *header = (struct wakeup_header *) __va(real_mode_header->wakeup_header); @@ -115,7 +117,8 @@ int x86_acpi_suspend_lowlevel(void) early_gdt_descr.address = (unsigned long)get_cpu_gdt_rw(smp_processor_id()); initial_gs = per_cpu_offset(smp_processor_id()); - smpboot_control = 0; + /* Force the startup into boot mode */ + saved_smpboot_ctrl = xchg(&smpboot_control, 0); #endif initial_code = (unsigned long)wakeup_long64; saved_magic = 0x123456789abcdef0L; @@ -128,6 +131,9 @@ int x86_acpi_suspend_lowlevel(void) pause_graph_tracing(); do_suspend_lowlevel(); unpause_graph_tracing(); + + if (IS_ENABLED(CONFIG_64BIT) && IS_ENABLED(CONFIG_SMP)) + smpboot_control = saved_smpboot_ctrl; return 0; } That's too bloody obvious, too self explaining, not enough duplicated code and does not need any fixups when the smpboot_control bits are changed later, right? Thanks, tglx