> + switch (op.op) { > + case VFIO_EEH_PE_DISABLE: > + ret = eeh_pe_set_option(pe, EEH_OPT_DISABLE); > + break; > + case VFIO_EEH_PE_ENABLE: > + ret = eeh_pe_set_option(pe, EEH_OPT_ENABLE); > + break; This could be simplified a bit more by moving the return from the end of the function into the switch statements. > - * Copyright Gavin Shan, IBM Corporation 2014. This notice needs to move over to vfio_iommu_spapr_tce.c. Otherwise looks good: Reviewed-by: Christoph Hellwig <hch@xxxxxx>