On Mon, 2022-06-27 at 13:41 -0700, Dave Hansen wrote: > On 6/27/22 03:31, Kai Huang wrote: > > > > +/* Page sizes supported by TDX */ > > > > +enum tdx_page_sz { > > > > + TDX_PG_4K, > > > > + TDX_PG_2M, > > > > + TDX_PG_1G, > > > > + TDX_PG_MAX, > > > > +}; > > > Are these the same constants as the magic numbers in Kirill's > > > try_accept_one()? > > try_accept_once() uses 'enum pg_level' PG_LEVEL_{4K,2M,1G} directly. They can > > be used directly too, but 'enum pg_level' has more than we need here: > > I meant this: > > + switch (level) { > + case PG_LEVEL_4K: > + page_size = 0; > + break; > > Because TDX_PG_4K==page_size==0, and for this: > > + case PG_LEVEL_2M: > + page_size = 1; > > where TDX_PG_2M==page_size==1 > > See? > > Are Kirill's magic 0/1/2 numbers the same as > > TDX_PG_4K, > TDX_PG_2M, > TDX_PG_1G, > > ? Yes they are the same. Kirill uses 0/1/2 as input of TDX_ACCEPT_PAGE TDCALL. Here I only need them to distinguish different page sizes. Do you mean we should put TDX_PG_4K/2M/1G definition to asm/tdx.h, and try_accept_one() should use them instead of magic 0/1/2? -- Thanks, -Kai