On Fri, Aug 20, 2021, Jing Zhang wrote: > Hi Sean, > > On Thu, Aug 19, 2021 at 3:37 PM Sean Christopherson <seanjc@xxxxxxxxxx> wrote: > > > > On Wed, Aug 18, 2021, Cannon Matthews wrote: > > > Since a guest has explictly asked for a vcpu to HLT, this is "useful work on > > > behalf of the guest" even though the thread is "blocked" from running. > > > > > > This allows answering questions like, are we spending too much time waiting > > > on mutexes, or long running kernel routines rather than running the vcpu in > > > guest mode, or did the guest explictly tell us to not doing anything. > > > > > > So I would suggest keeping the "halt" part of the counters' name, and remove > > > the "blocked" part rather than the other way around. We explicitly do not > > > want to include non-halt blockages in this. > > > > But this patch does include non-halt blockages, which is why I brought up the > > technically-wrong naming. Specifically, x86 reaches this path for any !RUNNABLE > > vCPU state, e.g. if the vCPU is in WFS. Non-x86 usage appears to mostly call > > this for halt-like behavior, but PPC looks like it has at least one path that's > > not halt-like. > > > > I doubt anyone actually cares if the stat is a misnomer in some cases, but at the > > same time I think there's opportunity for clean up here. E.g. halt polling if a > > vCPU is in WFS or UNINITIALIZED is a waste of cycles. Ditto for the calls to > > kvm_arch_vcpu_blocking() and kvm_arch_vcpu_unblocking() when halt polling is > > successful, e.g. arm64 puts and reloads the vgic, which I assume is a complete > > waste of cycles if the vCPU doesn't actually block. And kvm_arch_vcpu_block_finish() > > can be dropped by moving the one line of code into s390, which can add its own > > wrapper if necessary. > > > > So with a bit of massaging and a slight change in tracing behavior, I believe we > > can isolate the actual wait/halt and avoid "halted" being technically-wrong, and > > fix some inefficiencies at the same time. > > > > Jing, can you do a v2 of this patch and send it to me off-list? With luck, my > > idea will work and I can fold your patch in, and if not we can always post v2 > > standalone in a few weeks. Circling back to this with fresh eyes, limiting the state to "halted" would be wrong. I still stand by my assertion that non-halt states such as WFS should not go through halt polling, but the intent of the proposed stat is to differentiate between not running a vCPU because of a guest action and not running a vCPU because the host is not scheduling its task. E.g. on x86, if a vCPU is put into WFS for an extended time, the vCPU will not be run because of a guest action, not because of any host activity. But again, WFS has very different meaning than "halt", which was the basis for my original objection to the "halt_block" terminology. One option would be to invert the stat, e.g. vcpu->stat.runnable, but that has the downside of needed to be set somewhere outside of kvm_vcpu_block/halt(), and it would likely be difficult to come up with a name that isn't confusing, e.g. the vCPU would show up as "runnable" when mp_state!=RUNNABLE and it's not actively blocking. Back to bikeshedding the "halted" name, what about "blocking" or "waiting"? I.e. switch from past tense to present tense to convey that the _vCPU_ is "actively" blocking/waiting, as opposed to the vCPU being blocked by some host condition.