On 02/04/21 01:05, Sean Christopherson wrote:
+struct kvm_queued_exception {
+ bool valid;
+ u8 nr;
If we're refactoring all this code anyways, maybe change "nr" to something a
bit more descriptive? E.g. vector.
"nr" is part of the userspace structure, so consistency is an advantage too.
+ struct kvm_exception_payload {
+ bool valid;
+ unsigned long value;
u8 nested_apf;
- } exception;
+ } exception_payload;
Hmm, even if it's dead code at this time, I think the exception payload should
be part of 'struct kvm_queued_exception'. The payload is very much tied to a
single exception.
Agreed, when handling injected exceptions you can WARN that there is no
payload.
Paolo